Solaris commands - Sorted according to use

Solaris Commands

I would like to share you all the best sorted all solaris commands in this post. Though this was with me since long time I realized today, the need or ease in it,  hence sharing it with you all. I am sure this sorted list will definitely help you compared to any other command reference manual due to its way of presentation.

1.Disk Commands
26. /bin/mount -F hsfs -o ro /dev/sr0 /cdrom
/* Mount an ISO 9660 CDROM */
27. /usr/bin/iostat -E
/* Command to display drives statistics */
28. du -ad /var | sort -nr
/* Report the the disk used in /var in reverse order */
29. du -k .
/* Report disk usage in Kilobytes */
30. du -sk * | sort -nr | head
/* Shows the top ten largest files/directories */
31. du -sk *|sort -k1,1n
/* Reports total disk space used in Kilobytes in present directory */
32. du -sk .
/* Report total disk usage in Kilobytes */
33. fdformat -d -U
/* Format diskette */
34. mount -F hsfs -o ro `lofiadm -a /export/temp/software.iso` /mnt
/* Mount an ISO Image */
35. newfs -Nv /dev/rdsk/c0t0d0s1
/* To view the superfblocks available */
36. One-liner to copy a partition table
/* prtvtoc /dev/dsk/c1t2d0s2 | fmthard -s - /dev/rdsk/c1t3d0s2 */
37. prtvtoc /dev/rdsk/c0t0d0s2
/* Disk geometry and partitioning info */
38. prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2
/* Copy partition table from one disk to another */
39. quot -af
/* How much space is used by users in kilobytes */
40. volrmmount -i floppy
/* Mount a floppy or other media easily by its nickname. */

Driver Parameters
41. ndd /dev/ip ip_forwarding
/* Show the ip_forwarding variable in the kernel */
42. ndd /dev/ip ip_forwarding 1
/* Set the ip_forwarding variable in the kernel */
43. ndd /dev/ip \?
/* Show all IP variables set in the kernel */

File Manipulation
44. dos2unix | -ascii
/* Converts DOS file formats to Unix */
45. fold -w 180
/* To break lines to have maximum char */
46. split [-linecount] [file]
/* Split files into pieces */
47. [vi] : %s/existing/new/g
/* Search and Replace text in vi */
48. [vi] :set list
/* Show non-printing characters in vi */
49. [vi] :set nu
/* Set line numbers in vi */
50. [vi] :set ts=[num]
/* Set tab stops in vi */

2  File System
51. /sbin/uadmin x x
/* Syncs File Systems and Reboots systems fast */
52. awk ' END {print NR}' file_name
/* Display the Number of lines in a file */
53. cat /dev/null > filename
/* Zero's out the file without breaking pipe */
54. cksum [filename]
/* View the checksum value for the given file */
55. dd if=/dev/rdsk/... of=/dev/rdsk/... bs=4096
/* Make a mirror image of your boot disk */
56. df -k | grep dg| awk '{print $6}' |xargs -n 1 umount
/* Unmount all file systems in disk group dg */
57. fsck -F ufs -o b=97472 /dev/rdsk/c0t0d0s0
/* Check and repair a UFS filesystem on c0t0d0s0, using an alternate superblock */
58. fsck -F ufs -y /dev/rdsk/c0t0d0s0
/* Check a UFS filesystem on c0t0d0s0, repair any problems without prompting. */
59. fsck -F ufs /dev/rdsk/c0t0d0s0
/* Check a UFS filesystem on c0t0d0s0 */
60. gzip -d -c tarball.tgz | (cd /[dir];tar xf - ) &
/* Unpacking tarballs to diff location */
61. gzip -dc file1.tar.gz | tar xf -
/* Unpack .tar.gz files in place */
62. ln [-fhns]
/* Creating hard links and soft links */
63. ls -al | awk '$3 == "oracle" || $3 == "root" {print $9}'
/* List all file names by testing owner */
64. ls -l | sort +4n
/* List files by size */
65. ls -la | awk '{ print $5," ",$9 }' | sort -rn
/* File sizes of current directory */
66. ls -lR | awk '{total +=$5};END {print "Total size: " total/1024/1024 "MB" }'
/* Recursive directory size calculations in MB */
67. mkisofs -l -L -r -o [image-name].iso [directory]
/* Create an ISO image of a directory */
68. mount -F ufs -o rw,remount /
/* Used to remount root to make it writeable */
69. mount -o remount,logging /spare
/* Re-mount the ro file system rw and turn on ufs logging */
70. mount DOS fdisk partition from Solaris
/* mount -f pcfs /dev/dsk/c0d0p1 /export/dos */
71. mv [filename]{,.new_suffix}
/* Renaming file */
72. pax -rw . /newdir
/* Efficient alternative for copying directories */
73. prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2
/* Cloning Partitiontables */
74. rpm -q --queryformat '%{INSTALLPREFIX}\n' [packagename]
/* [Linux] Locate binaries */
75. tar cf - . | (cd /newdir ; tar xf -)
/* Recursively copy files and their permissions */
76. tar cvf filename.tar
/* Create a tape (tar) archive */
77. tar xvf filename.tar
/* Extract a tape (tar) archive */
78. X=$(wc -l <>
/* Count number of lines in a file into a variable (ksh) */
79. zcat
/* Extract the patch_file that is a compressed tar file */
80. zcat [cpio file] | cpio -itmv
/* Show the contents of a compressed cpio */

3 File Transfer
81. find . -depth | cpio -pdmv /path/tobe/copied/to
/* Fast alternative to cp -pr */
82. find . -follow | cpio -pdumL /path/tobe/copied/to
/* Copy with symbolic links to be followed */
83. get filename.suffix |"tar xf -"
/* Undocumented Feature of FTP */
84. Move any file(s) without actually touching them
/* ssh cd /some/directory \&\& tar cf - | ssh cd /some/direstory \&\& tar xvf - */
85. put "| tar cf - ." filename.tar
/* Undocumented Feature of FTP */
86. sendport
/* FTP command for transferring large numbers of files within the same control session */

General
87. /bin/printf '%d\n' '0x'
/* Converts hexadecimal number to decimal. */
88. /usr/bin/catman -w
/* Create windex databases for man page directories */
89. echo 'obase=16;255' | bc
/* Simple way to convert decimal to hex */
90. FQ_FILENAME=; echo ${FQ_FILENAME%/*}
/* Extract directory from fully-qualified file name. */
91. mailx -H -u
/* List out mail headers for specified user */
92. ps -ef | grep -i $@
/* Access common commands quicker */
93. set filec
/* Set file-completion for csh */
94. uuencode [filename] [filename] | mailx -s "Subject" [user to mail]
/* Send files as attachments */
95. xauth -f /home/${LOGNAME} extract - ${DISPLAY} | xauth merge -
/* Allow root to xdisplay after su */

Hardware
96. cfgadm
/* Verify reconfigurable hardware resources */
97. m64config -depth 8|24
/* Sets the screen depth of your M64 graphics accelerator */
98. m64config -prconf
/* Print M64 hardware configuration */
99. m64config -res 'video_mode'
/* Change the resolution of your M64 graphics accelerator */
100. prtpicl -v | grep sync-speed
/* Discover SCSI sync speed */

Kernel
101. /usr/sbin/modinfo
/* Display kernel module information */
102. /usr/sbin/modload
/* Load a kernel module */
103. /usr/sbin/modunload -i
/* Unload a kernel module */
104. /usr/sbin/sysdef
/* Show system kernal tunable details */
105. nm -x /dev/ksyms | grep OBJ | more
/* Tuneable kernel parameters */
106. update_drv -f [driver name]

/* Force a driver to reread it's .conf file without reloading the driver */

4.Memory
107. pagesize -a
/* Available page sizes for Solaris 9 */
108. prtconf | grep Mem
/* Display Memory Size of the local machine. */

Network Information
109. arp -a
/* Ethernet address arp table */
110. arp -d myhost
/* Delete an ethernet address arp table entry */
111. lsof -iTCP@10.20.2.9
/* Display open files for internet address */
112. named-xfer -z qantas.com.au -f /tmp/allip
/* Get All IP Addresses On A DNS Server */
113. ndd /dev/arp arp_cache_report
/* Prints ARP table in cache with IP and MAC address */
114. netstat -a | grep EST | wc -l
/* Displays number active established connections to the localhost */
115. netstat -a | more
/* Show the state of all the sockets on a machine */
116. netstat -i
/* Show the state of the interfaces used for TCP/IP traffice */
117. netstat -k hme0
/* Undocumented netstat command */
118. netstat -np
/* Similar to arp -a without name resolution */
119. netstat -r
/* Show the state of the network routing table for TCP/IP traffic */
120. netstat -rn
/* Displays routing information but bypasses hostname lookup. */
121. snoop -S -ta [machine]
/* Snoop for network packets and get size and time stamp entries. */
122. traceroute
/* Follow the route to the ipaddress */

Network Tuning
123. /sbin/ifconfig hme0:1 inet 10.210.xx.xxx netmask 255.255.0.0 broadcast
10.210.xxx.xxx
/* Virtual Interfaces */
124. /sbin/ifconfig hme0:1 up
/* Bring virtual interface up */
125. /usr/sbin/ndd -set /dev/hme adv_100fdx_cap 1
/* Nailling to 100Mbps */
126. ifconfig eth0 10.1.1.1 netmask 255.255.255.255
/* Add an Interface */
127. ifconfig eth0 mtu 1500
/* Change MTU of interface */
128. ndd -set /dev/ip ip_addrs_per_if 1-8192
/* To set more than 256 virtual ip addresses. */
129. ndd -set /dev/tcp tcp_recv_hiwat 65535
/* Increase TCP-receivebuffers on Sol2.5.1 systems with 100BaseTx */
130. ndd -set /dev/tcp tcp_xmit_hiwat 65535
/* Increase TCP-transmitbuffers on Sol2.5.1 systems with 100BaseTx */


5. Processes
131. /usr/proc/bin/ptree
/* Print the parent/child process 'tree' of a process */
132. /usr/proc/bin/pwdx
/* Print the working directory of a process */
133. /usr/ucb/ps -aux | more
/* Displays CPU % usage for each process in ascending order */
134. /usr/ucb/ps -auxww | grep
/* Gives the full listing of the process (long listing) */
135. coreadm -i core.%f.%p
/* Append program name and process id to core file names */
136. fuser -uc /var
/* Processes that are running from /var */
137. ipcs
/* Report inter-process communication facilities status */
138. kill -HUP `ps -ef | grep [p]roccess | awk '{print $2}'`
/* HUP any related process in one step */
139. lsof -i TCP:25
/* Mapping port with process */
140. pfiles
/* Shows processes' current open files */
141. pkill -n
/* Kill a process by name */
142. prstat -a
/* An alternative for top command */
143. ps -edf -o pcpu,pid,user,args
/* Nicely formatted 'ps' */
144. ps -ef | grep -i | awk '{ print $2 }'
/* Creates list of running PID by */
145. ps -ef | grep -i | awk '{ print $2 }'
/* Creates list of running PID by */
146. ps -ef | grep | grep -v grep | cut -c 10-15 | xargs kill -9
/* Find and kill all instances of a given process */
147. ps -ef | more
/* Show all processes running */
148. ps -ef|grep -v "0:00"|more
/* Gives you a list of any process with CPU time more than 0:00 */
149. ps -eo pid,args
/* List processes in simplified format */
150. ps -fu oracle|grep pmon
/* See which instances of Oracle are running */
151. top -b 1
/* Returns the process utilizing the most cpu and quits */

Resource Management
152. /usr/bin/ldd [filename]
/* List the dynamic dependencies of executable files */
153. /usr/proc/bin/pmap pid
/* Report address space map a process occupies */

Route Configuration
154. route add net 128.50.0.0 128.50.1.6 1
/* Add a route to the routing table */
155. route change 128.50.0.0 128.50.1.5
/* Changes the destination address for a route */
156. route delete net 128.50.0.0 128.50.1.6
/* Delete a route from the routing table */
157. route flush
/* Flush the routing table, which will remove all entries */
158. route get [hostname]
6
/* Which interface will be used to contact hostname */
159. route monitor
/* Monitor routing table lookup misses and changes */

Searching Items
160. cat | awk '{if (substr($1,1,1) == '#') print $0 }'
/* Print all lines in a file beginning with a specific character */
161. egrep "patterna|patternb"
/* Search for multiple patterns within the same file */
162. find -name "" -exec rm -rf {} \;
/* Recursively finds files by name and automatically removes them */
163. find . -type f -print | xargs grep -i [PATTERN]
/* Recursive grep on files */
164. find . ! -mtime - | /usr/bin/xargs rm -rf
/* Finds and removes files older than specified */
165. find . -exec egrep -li "str" {} \;
/* Find a string in files starting cwd */
166. find . -mtime -1 -type f
/* Find recently modified files */
167. find . -type f -exec grep "" {} \; -print
/* Find files (and content) containing within directory tree */
168. find . -type f -exec grep -l "" {} \;
/* Find files (and content) containing within directory tree */
169. find ./ \! -type f -exec ls -l {} \;|grep -v '^[l|p|s|-]'|grep -v 'total' | wc
-l
/* Find number of directories under the current directory */
170. find / -fstype nfs -prune -o fstype autofs -prune -o -name filename -print
/* find without traversing NFS mounted file systems */
171. find / -mtime <# of days>
/* Find files modified during the past # of days */
172. find / -perm -2 -a ! -type l
/* Find files writable by 'others' */
173. find / -type f |xargs ls -s | sort -rn |more
/* List files taking up the most system space */
174. find / -user
/* Find all files owned by */
175. find / -xdev -type f -ls|sort -nr -k 7,7
/* Find largest files in a file system */
176. find / | grep [file mask]
/* Fast way to search for files */
177. find /proc/*/fd -links 0 -type f -size +2000 -ls
/* Find large files moved or deleted and held open by a process */
178. grep /var/sadm/install/contents| awk '{ print $1 ' '
$10 }'
/* Find which package contains a particular file */
179. ls -lR | grep
/* Fast alternative to find. */
180. pkgchk -l -p /absolute/path/todir
/* Which package does this file belong to? */

Security
181. crypt abc && rm abc.cr
/* Decrypting a file that has been encrypted */
182. crypt abc.cr && rm abc
/* File encryption with crypt */
183. echo 'Please go away' > /etc/nologin
/* Stops users logging in */
184. find / -perm -0777 -type d -ls
/* Find all your writable directories */
185. find / -type f -perm -2000 -print
/* Find all SGID files */
186. find / -type f -perm -4000 -print
7
/* find all SUID files */
187. getpwenc [encryption scheme] password
/* Genrate passwords for LDAP Using 'getpwenc' Utility */
188. trap 'exit 0' 1 2 3 9 15
/* Trap specific signals and exit */
189. vi -x [filename]
/* Encrypt a file with vi editor */

Setting Term Options
190. stty erase ^?
/* Set the delete key to delete a character */
191. stty erase ^H
/* Set the backspace to delete a character */
192. stty sane
/* Reset terminal after viewing a binary file. */
193. tput rmacs
/* Reset to standard char set */

Snoop
194. snoop -d pcelx0
/* Watch all the packets on a device */
195. snoop -i /tmp/mylog -o /tmp/newlog host1
/* Filter out all the host1 packets and write them to a new logfile */
196. snoop -i /tmp/mylog -v -p101
/* Show verbose info on packet number 101 in the logfile */
197. snoop -i /tmp/mylog host1 host2
/* View packets from a logfile between hosts1 and host2 */
198. snoop -o /tmp/mylog pcelx0
/* Save all the packets from a device to a logfile */
199. snoop -s 120
/* Return the first 120 bytes in the packet header */
200. snoop -v arp
/* Capture arp broadcasts on your network */
201. snoop port [port-number]
/* Monitor particular port for traffic */

Swap Files
202. mkfile -nv 10m /export/disk1/myswap
/* Makes an empty 10 Megabyte swapfile in /export/disk */
203. mkfile -v 10m /export/disk1/myswap
/* Makes a 10 Megabyte swapfile in /export/disk */

Swap Space
204. swap -a /export/disk1/swapfile
/* Add a swap file */
205. swap -d /dev/dsk/c0t0d0s4
/* Delete a swap device */
206. swap -l
/* List the current swap devices */
207. swap -s
/* List the amount of swap space available */

System Configuration
208. /usr/sbin/eeprom auto-boot? false
/* Changes eeprom autoboot? setting without going to Ok prompt */
8
209. /usr/sbin/eeprom diag-switch? true
/* Set the system to perform diagnostics on the next reboot. */
210. /usr/sbin/eeprom local-mac-address?=true
/* Multiple Port Network Card Setting */
211. /usr/sbin/grpck
/* Check /etc/group file syntax */
212. /usr/sbin/pwck
/* Check /etc/passwd file syntax */
213. /usr/sbin/sys-unconfig
/* Clear host specific network configuration information */
214. /usr/sbin/useradd
/* Add a new user to the system */
215. drvconfig ; disks
/* Adding hot-plug disks to system */

System Information/Monitoring
216. /bin/echo "0t${stamp}>Y\n
/* Convert UNIX timestamp to something human-readable */
217. /usr/sbin/eeprom
/* Show eeprom parameters */
218. /usr/sbin/prtconf -vp
/* Show system configuration details */
219. coreadm -e log
/* Report global core */
220. grep "\-root" /var/adm/sulog | grep -v \+ | tail -25
/* List most recent attempts to switch to superuser account. */
221. isainfo -bv
/* Quickly checkout if machine is in 32 or 64 bit mode */
222. last
/* Tells who was or still is on the system */
223. logger -i
/* Log the process ID */
224. prtconf -pv | grep banner-name |awk -F\' ' { print $2 } ' | head -1
/* Show actual model name of machine */
225. prtdiag -v
/* System Diagnostics */
226. prtpicl -v | grep wwn
/* A command to find persistent binding of storage */
227. psradm -f [processor id]
/* Take processor offline */
228. psrinfo | wc -l
/* Display number of processors */
229. sar -u
/* Report CPU Utilization */
230. sar [ -aA ] [ -o filename ] t [ n ]
/* Provides cumulative reports about system activity. */
231. telnet 13 | grep ':'
/* Get the time on remote Unix machine */
232. uname -a
/* Displays system information */
233. uname -X
/* Displays system information */
234. vmstat 10
/* Displays summary of what the system is doing every 10 seconds */
235. who -b
/* Displays the date of the last system reboot. */
236. ypcat hosts | sort -n -t. +0 -1 +1 -2 +2 -3 +3 -4
/* Take the input of "ypcat hosts" or "cat /etc/inet/hosts" and sort by IP. */


4 comments to "Solaris commands - Sorted according to use"

Post a Comment

Whoever writes Inappropriate/Vulgar comments to context, generally want to be anonymous …So I hope U r not the one like that?
For lazy logs, u can at least use Name/URL option which doesn’t even require any sign-in, The good thing is that it can accept your lovely nick name also and the URL is not mandatory too.
Thanks for your patience
~Krishna(I love "Transparency")

Popular Posts

Enter your email address:

Buffs ...

Tags


Powered by WidgetsForFree

Archives